提交 9971edd0 编写于 作者: N Nicolas 'Pixel' Noble

Regenerate projects

上级 ec2b5e2a
......@@ -25,12 +25,12 @@
cmake_minimum_required(VERSION 3.5.1)
set(PACKAGE_NAME "grpc")
set(PACKAGE_VERSION "1.40.0-dev")
set(PACKAGE_VERSION "1.40.0-pre1")
set(gRPC_CORE_VERSION "18.0.0")
set(gRPC_CORE_SOVERSION "18")
set(gRPC_CPP_VERSION "1.40.0-dev")
set(gRPC_CPP_VERSION "1.40.0-pre1")
set(gRPC_CPP_SOVERSION "1.40")
set(gRPC_CSHARP_VERSION "2.40.0-dev")
set(gRPC_CSHARP_VERSION "2.40.0-pre1")
set(gRPC_CSHARP_SOVERSION "2.40")
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_TARNAME "${PACKAGE_NAME}-${PACKAGE_VERSION}")
......@@ -251,7 +251,7 @@ endif()
if (gRPC_XDS_USER_AGENT_IS_CSHARP)
# The value of the defines needs to contain quotes.
# See https://github.com/grpc/grpc/blob/fbf32836a418cc84f58786700273b65cb9174e1d/src/core/ext/xds/xds_api.cc#L854
add_definitions("-DGRPC_XDS_USER_AGENT_NAME_SUFFIX=\"csharp\"" "-DGRPC_XDS_USER_AGENT_VERSION_SUFFIX=\"2.40.0-dev\"")
add_definitions("-DGRPC_XDS_USER_AGENT_NAME_SUFFIX=\"csharp\"" "-DGRPC_XDS_USER_AGENT_VERSION_SUFFIX=\"2.40.0-pre1\"")
endif()
include(cmake/abseil-cpp.cmake)
......
......@@ -455,8 +455,8 @@ Q = @
endif
CORE_VERSION = 18.0.0
CPP_VERSION = 1.40.0-dev
CSHARP_VERSION = 2.40.0-dev
CPP_VERSION = 1.40.0-pre1
CSHARP_VERSION = 2.40.0-pre1
CPPFLAGS_NO_ARCH += $(addprefix -I, $(INCLUDES)) $(addprefix -D, $(DEFINES))
CPPFLAGS += $(CPPFLAGS_NO_ARCH) $(ARCH_FLAGS)
......
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/_metadata.py.template`!!!
__version__ = """1.40.0.dev0"""
__version__ = """1.40.0rc1"""
......@@ -1061,7 +1061,7 @@ if test "$PHP_GRPC" != "no"; then
-D_HAS_EXCEPTIONS=0 -DNOMINMAX -DGRPC_ARES=0 \
-DGRPC_POSIX_FORK_ALLOW_PTHREAD_ATFORK=1 \
-DGRPC_XDS_USER_AGENT_NAME_SUFFIX='"\"PHP\""' \
-DGRPC_XDS_USER_AGENT_VERSION_SUFFIX='"\"1.40.0dev\""')
-DGRPC_XDS_USER_AGENT_VERSION_SUFFIX='"\"1.40.0RC1\""')
PHP_ADD_BUILD_DIR($ext_builddir/src/core/ext/filters/census)
PHP_ADD_BUILD_DIR($ext_builddir/src/core/ext/filters/client_channel)
......
......@@ -22,7 +22,7 @@
Pod::Spec.new do |s|
s.name = 'gRPC-C++'
# TODO (mxyan): use version that match gRPC version when pod is stabilized
version = '1.40.0-dev'
version = '1.40.0-pre1'
s.version = version
s.summary = 'gRPC C++ library'
s.homepage = 'https://grpc.io'
......
......@@ -21,7 +21,7 @@
Pod::Spec.new do |s|
s.name = 'gRPC-Core'
version = '1.40.0-dev'
version = '1.40.0-pre1'
s.version = version
s.summary = 'Core cross-platform gRPC library, written in C'
s.homepage = 'https://grpc.io'
......
......@@ -21,7 +21,7 @@
Pod::Spec.new do |s|
s.name = 'gRPC-ProtoRPC'
version = '1.40.0-dev'
version = '1.40.0-pre1'
s.version = version
s.summary = 'RPC library for Protocol Buffers, based on gRPC'
s.homepage = 'https://grpc.io'
......
......@@ -21,7 +21,7 @@
Pod::Spec.new do |s|
s.name = 'gRPC-RxLibrary'
version = '1.40.0-dev'
version = '1.40.0-pre1'
s.version = version
s.summary = 'Reactive Extensions library for iOS/OSX.'
s.homepage = 'https://grpc.io'
......
......@@ -20,7 +20,7 @@
Pod::Spec.new do |s|
s.name = 'gRPC'
version = '1.40.0-dev'
version = '1.40.0-pre1'
s.version = version
s.summary = 'gRPC client library for iOS/OSX'
s.homepage = 'https://grpc.io'
......
......@@ -13,8 +13,8 @@
<date>2019-09-24</date>
<time>16:06:07</time>
<version>
<release>1.40.0dev</release>
<api>1.40.0dev</api>
<release>1.40.0RC1</release>
<api>1.40.0RC1</api>
</version>
<stability>
<release>beta</release>
......
......@@ -22,5 +22,5 @@
#include <grpcpp/grpcpp.h>
namespace grpc {
std::string Version() { return "1.40.0-dev"; }
std::string Version() { return "1.40.0-pre1"; }
} // namespace grpc
......@@ -38,6 +38,6 @@ namespace Grpc.Core
/// <summary>
/// Current version of gRPC C#
/// </summary>
public const string CurrentVersion = "2.40.0-dev";
public const string CurrentVersion = "2.40.0-pre1";
}
}
<!-- This file is generated -->
<Project>
<PropertyGroup>
<GrpcCsharpVersion>2.40.0-dev</GrpcCsharpVersion>
<GrpcCsharpVersion>2.40.0-pre1</GrpcCsharpVersion>
<GoogleProtobufVersion>3.15.8</GoogleProtobufVersion>
</PropertyGroup>
</Project>
......@@ -42,7 +42,7 @@ Pod::Spec.new do |s|
# exclamation mark ensures that other "regular" pods will be able to find it as it'll be installed
# before them.
s.name = '!ProtoCompiler-gRPCCppPlugin'
v = '1.40.0-dev'
v = '1.40.0-pre1'
s.version = v
s.summary = 'The gRPC ProtoC plugin generates C++ files from .proto services.'
s.description = <<-DESC
......
......@@ -42,7 +42,7 @@ Pod::Spec.new do |s|
# exclamation mark ensures that other "regular" pods will be able to find it as it'll be installed
# before them.
s.name = '!ProtoCompiler-gRPCPlugin'
v = '1.40.0-dev'
v = '1.40.0-pre1'
s.version = v
s.summary = 'The gRPC ProtoC plugin generates Objective-C files from .proto services.'
s.description = <<-DESC
......
......@@ -22,4 +22,4 @@
// instead. This file can be regenerated from the template by running
// `tools/buildgen/generate_projects.sh`.
#define GRPC_OBJC_VERSION_STRING @"1.40.0-dev"
#define GRPC_OBJC_VERSION_STRING @"1.40.0-pre1"
......@@ -22,5 +22,5 @@
// instead. This file can be regenerated from the template by running
// `tools/buildgen/generate_projects.sh`.
#define GRPC_OBJC_VERSION_STRING @"1.40.0-dev"
#define GRPC_OBJC_VERSION_STRING @"1.40.0-pre1"
#define GRPC_C_VERSION_STRING @"18.0.0"
......@@ -20,6 +20,6 @@
#ifndef VERSION_H
#define VERSION_H
#define PHP_GRPC_VERSION "1.40.0dev"
#define PHP_GRPC_VERSION "1.40.0RC1"
#endif /* VERSION_H */
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio/grpc/_grpcio_metadata.py.template`!!!
__version__ = """1.40.0.dev0"""
__version__ = """1.40.0rc1"""
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_admin/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_channelz/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_csds/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_health_checking/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_reflection/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_status/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_testing/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -14,4 +14,4 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/src/python/grpcio_tests/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
......@@ -57,7 +57,7 @@ end
ENV['CPPFLAGS'] = '-DGPR_BACKWARDS_COMPATIBILITY_MODE'
ENV['CPPFLAGS'] += ' -DGRPC_XDS_USER_AGENT_NAME_SUFFIX="\"RUBY\"" '
ENV['CPPFLAGS'] += ' -DGRPC_XDS_USER_AGENT_VERSION_SUFFIX="\"1.40.0.dev\"" '
ENV['CPPFLAGS'] += ' -DGRPC_XDS_USER_AGENT_VERSION_SUFFIX="\"1.40.0.pre1\"" '
output_dir = File.expand_path(RbConfig::CONFIG['topdir'])
grpc_lib_dir = File.join(output_dir, 'libs', grpc_config)
......
......@@ -14,5 +14,5 @@
# GRPC contains the General RPC module.
module GRPC
VERSION = '1.40.0.dev'
VERSION = '1.40.0.pre1'
end
......@@ -14,6 +14,6 @@
module GRPC
module Tools
VERSION = '1.40.0.dev'
VERSION = '1.40.0.pre1'
end
end
......@@ -14,5 +14,5 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/tools/distrib/python/grpcio_tools/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
PROTOBUF_VERSION = '3.15.8'
......@@ -14,5 +14,5 @@
# AUTO-GENERATED FROM `$REPO_ROOT/templates/tools/distrib/python/grpcio_tools/grpc_version.py.template`!!!
VERSION = '1.40.0.dev0'
VERSION = '1.40.0rc1'
PROTOBUF_VERSION = '3.15.8'
......@@ -40,7 +40,7 @@ PROJECT_NAME = "GRPC C++"
# could be handy for archiving the generated documentation or if some version
# control system is used.
PROJECT_NUMBER = 1.40.0-dev
PROJECT_NUMBER = 1.40.0-pre1
# Using the PROJECT_BRIEF tag one can provide an optional one line description
# for a project that appears at the top of each page and should give viewer a
......
......@@ -40,7 +40,7 @@ PROJECT_NAME = "GRPC C++"
# could be handy for archiving the generated documentation or if some version
# control system is used.
PROJECT_NUMBER = 1.40.0-dev
PROJECT_NUMBER = 1.40.0-pre1
# Using the PROJECT_BRIEF tag one can provide an optional one line description
# for a project that appears at the top of each page and should give viewer a
......
......@@ -40,7 +40,7 @@ PROJECT_NAME = "GRPC Objective-C"
# could be handy for archiving the generated documentation or if some version
# control system is used.
PROJECT_NUMBER = 1.40.0-dev
PROJECT_NUMBER = 1.40.0-pre1
# Using the PROJECT_BRIEF tag one can provide an optional one line description
# for a project that appears at the top of each page and should give viewer a
......
......@@ -40,7 +40,7 @@ PROJECT_NAME = "GRPC Objective-C"
# could be handy for archiving the generated documentation or if some version
# control system is used.
PROJECT_NUMBER = 1.40.0-dev
PROJECT_NUMBER = 1.40.0-pre1
# Using the PROJECT_BRIEF tag one can provide an optional one line description
# for a project that appears at the top of each page and should give viewer a
......
......@@ -40,7 +40,7 @@ PROJECT_NAME = "GRPC PHP"
# could be handy for archiving the generated documentation or if some version
# control system is used.
PROJECT_NUMBER = 1.40.0-dev
PROJECT_NUMBER = 1.40.0-pre1
# Using the PROJECT_BRIEF tag one can provide an optional one line description
# for a project that appears at the top of each page and should give viewer a
......
Markdown is supported
0% .
You are about to add 0 people to the discussion. Proceed with caution.
先完成此消息的编辑!
想要评论请 注册