提交 b0c895ff 编写于 作者: J Jack Franklin 提交者: Mathias Bynens

check chromium downloaded

上级 1b4e7a14
......@@ -4,7 +4,8 @@ set -e
# Pack the module into a tarball
npm pack
tarball="$(realpath puppeteer-*.tgz)"
cd "$(mktemp -d)"
TMPDIR="$(mktemp -d)"
cd $TMPDIR
# Check we can install from the tarball.
# This emulates installing from npm and ensures that:
# 1. we publish the right files in the `files` list from package.json
......@@ -12,6 +13,7 @@ cd "$(mktemp -d)"
# 3. Requiring Puppeteer from Node works.
npm install --loglevel silent "${tarball}"
node --eval="require('puppeteer')"
ls $TMPDIR/node_modules/puppeteer/.local-chromium/
# Again for Firefox
TMPDIR="$(mktemp -d)"
......
Markdown is supported
0% .
You are about to add 0 people to the discussion. Proceed with caution.
先完成此消息的编辑!
想要评论请 注册