未验证 提交 024b337b 编写于 作者: D DMehaffy 提交者: GitHub

Update node version requirements for v10 to v12 (#7409)

Signed-off-by: NDerrick Mehaffy <derrickmehaffy@gmail.com>
上级 91ace0d1
......@@ -53,6 +53,7 @@ The core team will review your pull request and will either merge it, request ch
## Contribution Prerequisites
- You have [Node](https://nodejs.org/en/) at v10.10.0+ only and [Yarn](https://yarnpkg.com/en/) at v1.2.0+.
- Node v14/v13 **are not supported yet**
- You are familiar with Git.
## Development Workflow
......
......@@ -100,7 +100,9 @@ Complete installation requirements can be found in the documentation under <a hr
**Node:**
- NodeJS >= 10.10
Please note at this time Node v14 **is not** supported
- NodeJS >= 10.10 <13
- NPM >= 6.x
**Database:**
......
......@@ -110,6 +110,29 @@ Additional guides for optional software additions that compliment or improve the
</InstallLink>
</div>
## Recommended requirements
To provide the best possible environment for Strapi there are a few requirements, these apply in both a development (local) as well as a staging and production workflow.
- Node LTS (v10 or V12) **Note that Node v14 is not currently supported**
- Typical standard build tools for your OS (the `build-essentials` package on most Debian-based systems)
- At least 1 CPU core (Highly recommended at least 2)
- At least 2 GB of RAM (Moderately recommended 4)
- Minimum required storage space recommended by your OS or 32 GB of **free** space
- A supported database version
- MySQL >= 5.6
- MariaDB >= 10.1
- PostgreSQL >= 10
- SQLite >= 3
- MongoDB >= 3.6
- A supported operating system
- Ubuntu >= 18.04 (LTS-Only)
- Debian >= 9.x
- CentOS/RHEL >= 8
- macOS Mojave or newer (ARM not supported)
- Windows 10
- Docker - [docker repo](https://github.com/strapi/strapi-docker)
## Application Configuration
### 1. Configure
......
......@@ -38,7 +38,7 @@
"uuid": "getstarted"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE"
......
......@@ -93,7 +93,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -39,7 +39,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"gitHead": "231263a3535658bab1e9492c6aaaed8692d62a53"
......
......@@ -120,7 +120,7 @@
}
],
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -56,7 +56,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -43,7 +43,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -23,7 +23,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -40,7 +40,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -40,7 +40,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -41,7 +41,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -47,7 +47,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -40,7 +40,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -40,7 +40,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -40,7 +40,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -42,7 +42,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -6,7 +6,7 @@
"dist"
],
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"author": {
......
......@@ -39,7 +39,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -41,7 +41,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -39,7 +39,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -59,7 +59,7 @@
"url": "git://github.com/strapi/strapi.git"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -46,7 +46,7 @@
"url": "git://github.com/strapi/strapi.git"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -66,7 +66,7 @@
}
],
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -37,7 +37,7 @@
"url": "git://github.com/strapi/strapi.git"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -45,7 +45,7 @@
}
],
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -48,7 +48,7 @@
}
],
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -53,7 +53,7 @@
"url": "git://github.com/strapi/strapi.git"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -36,7 +36,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -39,7 +39,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -39,7 +39,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -38,7 +38,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -40,7 +40,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -39,7 +39,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -34,7 +34,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -14,7 +14,7 @@
"streamifier": "^0.1.1"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"gitHead": "231263a3535658bab1e9492c6aaaed8692d62a53"
......
......@@ -41,7 +41,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
......@@ -85,7 +85,7 @@
"url": "https://github.com/strapi/strapi/issues"
},
"engines": {
"node": ">=10.10.0",
"node": ">=10.10.0 <13",
"npm": ">=6.0.0"
},
"license": "SEE LICENSE IN LICENSE",
......
Markdown is supported
0% .
You are about to add 0 people to the discussion. Proceed with caution.
先完成此消息的编辑!
想要评论请 注册