提交 e50034a9 编写于 作者: H heyanlong

docs

上级 6235dbce
[submodule "sky-php7ext/protos"]
[submodule "apache/incubator-skywalking-data-collect-protocol"]
path = src/protos
url = https://github.com/apache/incubator-skywalking-data-collect-protocol.git
Sky Walking for php SDK| [中文](README_ZH.md)
==========
**SkyWalking php SDK**: A client tool developed for PHP using SkyWalking APM tools. (It is a pity that it only supports checking curl currently.)
SkyWalking APM : https://github.com/apache/incubator-skywalking
# SkyWalking PHP
* Automatic probe for PHP. **You don't need to modify the application code.**
* It is a PHP extension developed by zendAPI.
* It can hook automatically for monnitoring nodes and collecting logs.
* It transfers with header informations automatically.
* Manual probe.
* It is a php extension and contains some php classes.
* It can compatible any versions of php.You can look over the codes in the class 'SkyWalking'.
* You need to add business codes to monnitor.
<img src="https://skywalkingtest.github.io/page-resources/3.0/skywalking.png" alt="Sky Walking logo" height="90px" align="right" />
# Dep
* libuuid
* gcc 4.9+
* pkg-config
* grpc
* protoc
* php 7+
SkyWalking PHP is the PHP instrumentation agent, which is compatible with [Apache SkyWalking(Incubating) APM](https://github.com/apache/incubator-skywalking) backend and others compatible agents/SDKs
## Documents
* [Document in English](docs/README.md)
# Install
1. build php extension
```shell
git clone --recurse-submodules https://github.com/SkywalkingContrib/skywalking-php-sdk.git
cd sky-php7ext
phpize && ./configure && make && make install
```
## Support List
1. CURL
2. make report_client
```shell
cd sky-php7ext/report
make
```
# Config
* php.ini
```shell
extension=skywalking.so
skywalking.app_code = app_code
skywalking.grpc = 127.0.0.1:11800
```
# Run
```shell
php-fpm
./report_client 120.0.0.1:11800 /tmp
```
# Apply to
* version 1.0 applies to Skywalking 3.1 .
* version 2.0 applies to Skywalking 3.X .
* version 5.0 applies to Skywalking 5.X .
# In the future.
* more php versions.
* more os.
# Contact Us
* Submit an issue
* QQ Group: 155841680
\ No newline at end of file
* Submit an issue
* Mail list: dev@skywalking.apache.org
* [Gitter](https://gitter.im/openskywalking/Lobby)
* QQ Group: 155841680, 392443393
\ No newline at end of file
Sky Walking SDK for PHP | [English](README.md)
==========
**SkyWalking php SDK**: 针对SkyWalking APM工具为php开发的客户端工具 (目前只支持写日志方式和只针对curl检测)
SkyWalking APM : https://github.com/apache/incubator-skywalking
* PHP 自动探针 **不需要修改应用程序代码**
* 使用zendAPI开发的 php扩展
* 自动钩子,自动SkyWalking节点收集日志。
* 自动链路header传输
* 手动探针
* php扩展 和 php代码sdk类包
* php代码SkyWalking类进行php各种版本兼容
* 需要植入业务代码进行监控
# 使用安装
* php扩展包(https://github.com/SkywalkingContrib/skywalking-php-sdk/blob/master/sky-php7ext/README_ZH.md)
* php代码类包(https://github.com/SkywalkingContrib/skywalking-php-sdk/blob/master/sdk-php/README_ZH.md)
# 对应版本支持
* 1.0对应版本:Skywalking 3.1
* 2.0对应版本:Skywalking 3.x
* 5.0对应版本:Skywalking 5.x
# 将要完成
* 其它php版本扩展支持
* 更多系统支持
# 联系
* 直接提交Issue
* QQ群: 155841680
\ No newline at end of file
# Documents
* Quick Start
* [Quick start](quick-start.md)
* [Install php agent](install-agent.md)
# Dep
* libuuid
* gcc 4.9+
* pkg-config
* grpc
* protoc
* php 7+
# Install
1. build php extension
```shell
git clone --recurse-submodules https://github.com/SkywalkingContrib/skywalking-php-sdk.git
phpize && ./configure && make && make install
```
2. make report_client
```shell
cd src/report
make
```
# Config
* php.ini example
```shell
extension=skywalking.so
skywalking.version = 5
skywalking.app_code = app_code
skywalking.grpc = 127.0.0.1:11800
```
# Run
example
```shell
php-fpm
./report_client 120.0.0.1:11800 /tmp
```
\ No newline at end of file
# todo
\ No newline at end of file
.deps
*.lo
*.la
.libs
acinclude.m4
aclocal.m4
autom4te.cache
build
config.guess
config.h
config.h.in
config.log
config.nice
config.status
config.sub
configure
configure.in
include
install-sh
libtool
ltmain.sh
Makefile
Makefile.fragments
Makefile.global
Makefile.objects
missing
mkinstalldirs
modules
run-tests.php
tests/*/*.diff
tests/*/*.out
tests/*/*.php
tests/*/*.exp
tests/*/*.log
tests/*/*.sh
.idea
# PHP SkyWalking Class: SkyWalking PHP client
---
- [Installation](#installation)
- [Requirements](#requirements)
- [Quick Start and Examples](#quick-start-and-examples)
---
### Installation
To install PHP SkyWalking extend, simply:
copy ini to php.ini
git clone https://github.com/SkywalkingContrib/skywalking-php-sdk.git
cd skywalking-php-sdk/sky-php7ext
phpize
./configure
make -j [number_of_processor_cores] # eg. make -j 4
make install
### Requirements
the current phpext works with PHP 7.0-7.9.99 。
this extension references something external, use with: pphcurl、phpjson and phpstandard
need to install, Please refer to: https://github.com/grpc/grpc/blob/master/INSTALL.md
### Documentation
- https://github.com/OpenSkywalking/skywalking/wiki
### Quick Start and Examples
set php.ini skywalking.auto_open = On (Automatic writing **Ignore the following**)
\ No newline at end of file
# PHP SkyWalking Class: SkyWalking PHP client
---
- [安装](#installation)
- [要求](#requirements)
- [Quick Start and Examples](#quick-start-and-examples)
---
### Installation
快速安装
复制ini内容到php.ini
git clone https://github.com/SkywalkingContrib/skywalking-php-sdk.git
cd skywalking-php-sdk/sky-php7ext
phpize
./configure
make -j [number_of_processor_cores] # eg. make -j 4
make install
### Requirements
扩展支持版本 7.0-7.9.99 。
这个扩展需要其他扩展支持: pphcurl、phpjson和phpstandard 包
需要安装GRPC 请参照 : https://github.com/grpc/grpc/blob/master/INSTALL.md
### 快速启动
设置 php.ini skywalking.auto_open = On (自动开启信息抓取 **Ignore the following**)
Markdown is supported
0% .
You are about to add 0 people to the discussion. Proceed with caution.
先完成此消息的编辑!
想要评论请 注册